Upgrading PolySync

The license tool has a mechanism to check for PolySync updates. If an update is found, it will be downloaded to the local machine (`~/Downloads`) as a tarball. The tarball can be used along with the [Manual Install Of PolySync](/articles/?p=200) to upgrade to a new PolySync release. See below for an example. To check for an update, call the license tool: ```bash $ polysync-license-tool -u ``` The file name is similar to: `polysync-release-2.*.tar.gz` This command will only work if there is an active PolySync license, an active Internet connection, and an available update. If PolySync has already been installed, then the following will backup the existing installation, and perform all steps required to upgrade PolySync from a tarball release package. This will download the new release from downloads.polysnc.io. ```bash $ echo $PSYNC_HOME /usr/local/polysnc $ tar cfz /opt/polysync-backup-this-is-the-date.tar.gz /usr/local/polysync $ rm -rf /usr/local/polysync $ cd ~/Downloads $ tar xf polysync-release-new-version.tar.gz $ mv polysync/ /usr/local ``` This will create the required sybolic links for the Xsens Dynamic Driver interface. ```bash $ sudo ldconfig ``` This will download an **existing** license for the server (it requires Internet). ```bash $ polysync-license-tool -a ```